Troy Office Phone System Reset

Incident Report for E7 Solutions

Resolved

The Troy office phone system reset is complete.
Posted Aug 12, 2020 - 10:47 EDT

Identified

The phone system in the Troy office is being reset
Posted Aug 12, 2020 - 10:45 EDT
This incident affected: E7 Solutions (E7 Phone System).